Reset Your Own Password

Reset Your Own Password

Issue/Environment/User Role

A Student, Faculty, or Staff member needs to reset their password for USA.edu email, Blackboard, and other Single Sign On resources.

Cause

Password has expired or been forgotten.

Resolution

  1. Go to the myUSA portal (my.usa.edu), and click on the Password Self-Service link on the left side of the page:                                                                               mceclip0.png
  2. Enter your USA.edu email as the User ID, as well as the characters beneath, and click next:mceclip1.png
  3. Select a verification method, re-enter the full method, and enter the verification code sent to your verification method (if this is not set-up skip to step 5).
  4. You will be presented with a are to enter a new password. Your USA.edu email password will be immediately reset, but other resources (such as Blackboard) can take up to fifteen minutes to be reset.
  5. If you have not already setup password reset, go back to the myUSA portal home page and select Tech Support to the left of the page:                                   mceclip2.png
  6. Scroll down the new page that opens to “Password Services” located on the right side of the page:mceclip3.png
  7. Within Password Service, select Password Reset Enrollment and then select Password Self-Service Registration:                                                      mceclip4.png
  8. You will now sign in using your email and email password, and will be prompted to “Not lose your password again.” You will then set up verification methods for Password Self-Service.
  9. After these verification methods are setup, go through steps 1 though 4.
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